Jump to content

2022 HWbot Team Cup submission deadline

  • Days
  • Hours
  • Minutes
  • Seconds

We need your submissions for Team EHW!

Please see our: Forum Topic and get in on the action.

Welcome to ExtremeHW

Welcome to ExtremeHW, you must register to view or post in our community, but don't worry this is a simple FREE process that requires minimal information for you to signup. Be a part of ExtremeHW creating an account. 

 

Registered users can: 

  • Start new topics and reply to others.
  • Show off your PC using our Rig Creator feature.
  • Subscribe to topics and forums to get updates.
  • Get your own profile page to customize.
  • Send personal messages to other members.
  • Take advantage of site exclusive features.
  • Upgrade to Premium to unlock additional sites features.
IGNORED

HD7970 not POST'ing


pioneerisloud
 Share

Recommended Posts

I remember this being an issue for people with LGA 1155 back in the day originally, but I don't recall hearing about people having this problem with AMD boards.

Anybody know where I can start looking to fix this problem of my ASRock 890FX Deluxe5 (BIOS 2.00) not POST'ing with a Gigabyte Windforce HD7970 Rev 2.1?  The board works fine, attempts to boot up just fine with a GeForce GT310 installed.  The card works fine, I just pulled it a few days ago from my 990FX / FX 8350 rig.

If the card is installed alone in the 890FX board, I just get an "error code 97" on the little display on the bottom of the board, and no picture at all, and no POST beep.

It's got to be a BIOS issue, but there's no later BIOS's for the board that address anything like this.  And I can't seem to find any GOOD results for the Windforce v2.1 being flashed to a different BIOS either.

Owned

 Share

CPU: Ryzen 3600 @ 4.3GHz, 1867MHz IF
AUDIO: Fosi Audio 300w Desktop Subwoofer Amp
MOTHERBOARD: ASRock B450M Pro 4
RAM: 32GB (2x16GB) GSkill DDR4-3600 @ 3733, 16-19-19-39
GPU: Ref Powercolor RX 5700XT @ 2050 / 1800
SSD/NVME: 1TB Mushkin Enhanced Pilot-E NVME
SSD/NVME 2: 3x 2TB Crucial BX500 RAID0
PSU: Silverstone 850w Gold
Full Rig Info

Owned

 Share

CPU: Phenom 9850
MOTHERBOARD: Asus M4A79 Deluxe
RAM: 8GB (4x2GB) Kingston HyperX DDR2-800
PSU: eVGA 600BQ
GPU: Sapphire Dual X HD6970 2GB
SSD/NVME: Crucial BX500 240GB
HDD: 2x Toshiba 3TB 7200RPM RAID0
CPU COOLER: T.R.U.E. 120
Full Rig Info

Owned

 Share

CPU: Ryzen 5800x
GPU: MSI RX 6900XT Triple X
PSU: Seasonic Focus GX Gold 1000w
CPU COOLER: EKWB EK-AIO Basic 240mm
MOTHERBOARD: Asus ROG Strix B550-I Gaming
SSD/NVME: Silicon Power 512GB Gen3 NVME
HDD: 2x WD Black 2.5" 500GB RAID0
RAM: Mushkin Redline Black 32GB (2x16GB) DDR4-4000
Full Rig Info
Link to comment
Share on other sites

So far, here's what I've done.....ALMOST successfully.

 

1)  Flashed the 7970 to the older F41 BIOS available directly from Gigabyte.  The newer F3 BIOS (and leaked F8 BIOS) didn't want to POST in the 890FX.
2)  The above F41 BIOS made the card unstable with 3D, BUT....it works in the 890FX.
3)  Flashed the 890FX from BIOS 2.00 to 2.01 beta.  Seems to work?  Hasn't been very stable since the flash, but could be the GPU BIOS.
4)  Switched 7970 BIOS switch to #2 once 890FX was flashed.  It POST'ed.  Never did get it to boot again.
Note:  After the 890FX BIOS flash, the BIOS was then UEFI instead of old school.  Might be the bootup issue?
5)  I'm now installing Win10 (again) using UEFI.  F2 (stock) BIOS on the 7970 and latest beta 2.01 BIOS on the board.

 

Seems to be working now.  The card is 3D stable in the 990FX Sabertooth again using stock F2 BIOS on the card, whereas it wasn't on the F41 there either.  It POST'd and installed Windows on the 890FX now.  Maybe, just maybe it'll work???

EDIT:  It's working.  The 890FX now has the 7970 installed, 3D is working.  So yeah, needed to update the motherboard's BIOS to a beta.  Kind of a PITA since the 7970 is the card I bought for the rig.  Stress testing the OC's now. 🙂

Edited by pioneerisloud
  • Thanks 3

Owned

 Share

CPU: Ryzen 3600 @ 4.3GHz, 1867MHz IF
AUDIO: Fosi Audio 300w Desktop Subwoofer Amp
MOTHERBOARD: ASRock B450M Pro 4
RAM: 32GB (2x16GB) GSkill DDR4-3600 @ 3733, 16-19-19-39
GPU: Ref Powercolor RX 5700XT @ 2050 / 1800
SSD/NVME: 1TB Mushkin Enhanced Pilot-E NVME
SSD/NVME 2: 3x 2TB Crucial BX500 RAID0
PSU: Silverstone 850w Gold
Full Rig Info

Owned

 Share

CPU: Phenom 9850
MOTHERBOARD: Asus M4A79 Deluxe
RAM: 8GB (4x2GB) Kingston HyperX DDR2-800
PSU: eVGA 600BQ
GPU: Sapphire Dual X HD6970 2GB
SSD/NVME: Crucial BX500 240GB
HDD: 2x Toshiba 3TB 7200RPM RAID0
CPU COOLER: T.R.U.E. 120
Full Rig Info

Owned

 Share

CPU: Ryzen 5800x
GPU: MSI RX 6900XT Triple X
PSU: Seasonic Focus GX Gold 1000w
CPU COOLER: EKWB EK-AIO Basic 240mm
MOTHERBOARD: Asus ROG Strix B550-I Gaming
SSD/NVME: Silicon Power 512GB Gen3 NVME
HDD: 2x WD Black 2.5" 500GB RAID0
RAM: Mushkin Redline Black 32GB (2x16GB) DDR4-4000
Full Rig Info
Link to comment
Share on other sites

Glad it seems to be fixed, thanks for updating us with the solution 🙂

  • Thanks 1

Owned

 Share

CPU: AMD 3950X
MOTHERBOARD: ASRock X570 Taichi
RAM: G.SKILL Trident Z Neo 32GB
PSU: Corsair RM1000x
GPU: EVGA RTX 3090 FTW3 Ultra Gaming
CASE: Fractal Design Define 7XL
SSD/NVME: ADATA GPX Gammix S70 1TB
FANS: Corsair ML140 Red x13
Full Rig Info

Owned

 Share

CPU: i7 7700k Delidded
MOTHERBOARD: ASRock Z170 Extreme 7+
RAM: Corsair Vengeance LPX 8GB
PSU: Corsair RM850x
GPU: ASUS RTX 2080Ti ROG Strix Gaming OC
CASE: Fractal Design Meshify S2
FANS: Corsair ML140 Pro RGB x3
FANS 2: NoiseBlocker M12-P x3
Full Rig Info

Owned

 Share

CPU: i9 10900x
MOTHERBOARD: ASUS WS X299 SAGE/10G
RAM: Corsair Vengeance LPX 32GB
PSU: Corsair AX1600i
GPU: EVGA RTX 3080Ti FTW3 Ultra Gaming
GPU 2: MSI RTX 2080 Super Gaming X Trio
GPU 3: MSI RTX 3060 Gaming X
SSD/NVME: ADATA SU650 240GB
Full Rig Info
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

This Website may place and access certain Cookies on your computer. ExtremeHW uses Cookies to improve your experience of using the Website and to improve our range of products and services. ExtremeHW has carefully chosen these Cookies and has taken steps to ensure that your privacy is protected and respected at all times. All Cookies used by this Website are used in accordance with current UK and EU Cookie Law. For more information please see our Privacy Policy