Jump to content

Welcome to ExtremeHW

Welcome to ExtremeHW, you must register to view or post in our community, but don't worry this is a simple FREE process that requires minimal information for you to signup. Be a part of ExtremeHW creating an account. 

 

Registered users can: 

  • Start new topics and reply to others.
  • Show off your PC using our Rig Creator feature.
  • Subscribe to topics and forums to get updates.
  • Get your own profile page to customize.
  • Send personal messages to other members.
  • Take advantage of site exclusive features.
  • Upgrade to Premium to unlock additional sites features.
IGNORED

New AMD drivers for 6 series cards fixes ppd in [email protected]


Recommended Posts

https://drivers.amd.com/drivers/amd-software-adrenalin-edition-22.7.1-win10-win11-july26.exe  Looks like they fixed it for 6 series cards doesnt help my 5700 tho. 5700 still at 1.6 ppd but 6800 went from 1.6 to 4.6 million ppd!! Just in time for the Challenge.

  • Thanks 1
  • Respect 4

Owned

 Share

CPU: 5800x
MOTHERBOARD: Gigabyte x570 Elite wifi
RAM: T-Force 3600 DDR4 CL16 32 GB
PSU: Thermaltake 1350
GPU: 6800 XT
SSD/NVME: Samsung 980 512 GB
CPU COOLER: Ventoo V5
CASE: Antec P280
Full Rig Info
Link to comment
Share on other sites

EHW Review Manager

Wow, that's insane. Good deal. 

Owned

 Share

CPU: Intel 9900K
MOTHERBOARD: ASUS z390-A
GPU: EVGA RTX 3070Ti FTW
RAM: Patriot Viper Steel DDR4-4400
SSD/NVME: Samsung Evo 970
SSD/NVME 2: Samsung Evo 970
Full Rig Info
Link to comment
Share on other sites

EHW Social Media Manager
599 225
5 hours ago, mx500torid said:

https://drivers.amd.com/drivers/amd-software-adrenalin-edition-22.7.1-win10-win11-july26.exe  Looks like they fixed it for 6 series cards doesnt help my 5700 tho. 5700 still at 1.6 ppd but 6800 went from 1.6 to 4.6 million ppd!! Just in time for the Challenge.

Finally thank you for sharing this!

Wonder why it took so long.

 

Will try it tomorrow when i get back home.

 

😀

Owned

 Share

MOTHERBOARD: Msi Z690 A
CPU: Intel 12700K P5.1 E4.1 U4.1 1.3V
RAM: OLOY + GSKILL 4x16 3600 Cl 14-14-14 Gear 2
PSU: Corsair RM1000X
GPU: Sapphire 6800XT
MONITOR: LG CX48 OLED
MONITOR 2: Samsung HMD Odyssey Plus (VR) OLED
CASE: Corsair 4000D Airflow
Full Rig Info

Owned

 Share

CPU: Ryzen 5900HX
RAM: 2x16gb 32gb 3200mhz cl22 Timetec Dual Rank
GPU: RX 6800M 12GB
MONITOR: 1080P 300hz
SSD/NVME: WD SN850 2TB + SN770 1TB
Full Rig Info
Link to comment
Share on other sites

wonder if it fixed an issue I had where I had to disable smart access memory or I'd have a driver crash when folding.... doing a short test now... so far PPD estimates are way up... I may join in the comp just to see.

$3000

Owned

 Share

CPU: R9 5950x
MOTHERBOARD: ASUS TUF B550
RAM: Gskill Ripjaws 3600 C14 32GB
GPU: Reference 6900xt
SSD/NVME: 2TB PNY XLR8 main drive
SSD/NVME 2: Kingston 2TB NVME Game drive
HDD: 18TB in 4 mass storage drives
CPU COOLER: 120x360 custom loop
Full Rig Info
Link to comment
Share on other sites

EHW Social Media Manager
599 225

If anyone want to see the release note it include many other improvement.

https://www.amd.com/en/support/kb/release-notes/rn-rad-win-22-7-1

 

 

My 6800xt went from 900k-1.4m to now 4.5m

 

🥳:wheee:

Edited by bonami2
  • Thanks 1

Owned

 Share

MOTHERBOARD: Msi Z690 A
CPU: Intel 12700K P5.1 E4.1 U4.1 1.3V
RAM: OLOY + GSKILL 4x16 3600 Cl 14-14-14 Gear 2
PSU: Corsair RM1000X
GPU: Sapphire 6800XT
MONITOR: LG CX48 OLED
MONITOR 2: Samsung HMD Odyssey Plus (VR) OLED
CASE: Corsair 4000D Airflow
Full Rig Info

Owned

 Share

CPU: Ryzen 5900HX
RAM: 2x16gb 32gb 3200mhz cl22 Timetec Dual Rank
GPU: RX 6800M 12GB
MONITOR: 1080P 300hz
SSD/NVME: WD SN850 2TB + SN770 1TB
Full Rig Info
Link to comment
Share on other sites

This driver broke gaming for me with my 6900XT.  I kept getting a black screen / monitor shutting off everytime I'd try to play a game.  Swapped back to the latest WHQL's and it fixed it.  Normally I'm a huge advocate for AMD drivers, I absolutely love them.  But....yeah, this one broke for me. -_-

Edited by pioneerisloud
  • Respect 1

Owned

 Share

CPU: Ryzen 3600 @ 4.3GHz, 1867MHz IF
AUDIO: Fosi Audio 300w Desktop Subwoofer Amp
MOTHERBOARD: ASRock B450M Pro 4
RAM: 32GB (2x16GB) GSkill DDR4-3600 @ 3733, 16-19-19-39
GPU: Ref Powercolor RX 5700XT @ 2050 / 1800
SSD/NVME: 1TB Mushkin Enhanced Pilot-E NVME
SSD/NVME 2: 3x 2TB Crucial BX500 RAID0
PSU: Silverstone 850w Gold
Full Rig Info

Owned

 Share

CPU: Phenom 9850
MOTHERBOARD: Asus M4A79 Deluxe
RAM: 8GB (4x2GB) Kingston HyperX DDR2-800
PSU: eVGA 600BQ
GPU: Sapphire Dual X HD6970 2GB
SSD/NVME: Crucial BX500 240GB
HDD: 2x Toshiba 3TB 7200RPM RAID0
CPU COOLER: T.R.U.E. 120
Full Rig Info

Owned

 Share

CPU: Ryzen 5800x
GPU: MSI RX 6900XT Triple X
PSU: Seasonic Focus GX Gold 1000w
CPU COOLER: EKWB EK-AIO Basic 240mm
MOTHERBOARD: Asus ROG Strix B550-I Gaming
SSD/NVME: Silicon Power 512GB Gen3 NVME
HDD: 2x WD Black 2.5" 500GB RAID0
RAM: Mushkin Redline Black 32GB (2x16GB) DDR4-4000
Full Rig Info
Link to comment
Share on other sites

EHW Social Media Manager
599 225
11 minutes ago, pioneerisloud said:

This driver broke gaming for me with my 6900XT.  I kept getting a black screen / monitor shutting off everytime I'd try to play a game.  Swapped back to the latest WHQL's and it fixed it.  Normally I'm a huge advocate for AMD drivers, I absolutely love them.  But....yeah, this one broke for me. -_-

Haven't updated my mobile 6800m so I can't says. Desktop seem to be folding fine with the new driver but did crash like four time for no reason in the first hour.

Owned

 Share

MOTHERBOARD: Msi Z690 A
CPU: Intel 12700K P5.1 E4.1 U4.1 1.3V
RAM: OLOY + GSKILL 4x16 3600 Cl 14-14-14 Gear 2
PSU: Corsair RM1000X
GPU: Sapphire 6800XT
MONITOR: LG CX48 OLED
MONITOR 2: Samsung HMD Odyssey Plus (VR) OLED
CASE: Corsair 4000D Airflow
Full Rig Info

Owned

 Share

CPU: Ryzen 5900HX
RAM: 2x16gb 32gb 3200mhz cl22 Timetec Dual Rank
GPU: RX 6800M 12GB
MONITOR: 1080P 300hz
SSD/NVME: WD SN850 2TB + SN770 1TB
Full Rig Info
Link to comment
Share on other sites

solid as a rock for me. Gaming, folding both working well. Both gpus undervolted.

  • Thanks 1
  • Respect 1

Owned

 Share

CPU: 5800x
MOTHERBOARD: Gigabyte x570 Elite wifi
RAM: T-Force 3600 DDR4 CL16 32 GB
PSU: Thermaltake 1350
GPU: 6800 XT
SSD/NVME: Samsung 980 512 GB
CPU COOLER: Ventoo V5
CASE: Antec P280
Full Rig Info
Link to comment
Share on other sites

EHW Social Media Manager
599 225
44 minutes ago, mx500torid said:

solid as a rock for me. Gaming, folding both working well. Both gpus undervolted.

Good to know will try it on my laptop when i have time 😀

Owned

 Share

MOTHERBOARD: Msi Z690 A
CPU: Intel 12700K P5.1 E4.1 U4.1 1.3V
RAM: OLOY + GSKILL 4x16 3600 Cl 14-14-14 Gear 2
PSU: Corsair RM1000X
GPU: Sapphire 6800XT
MONITOR: LG CX48 OLED
MONITOR 2: Samsung HMD Odyssey Plus (VR) OLED
CASE: Corsair 4000D Airflow
Full Rig Info

Owned

 Share

CPU: Ryzen 5900HX
RAM: 2x16gb 32gb 3200mhz cl22 Timetec Dual Rank
GPU: RX 6800M 12GB
MONITOR: 1080P 300hz
SSD/NVME: WD SN850 2TB + SN770 1TB
Full Rig Info
Link to comment
Share on other sites

2 hours ago, mx500torid said:

solid as a rock for me. Gaming, folding both working well. Both gpus undervolted.

I was having the same issue a while back with both my 6900XT and my 5700XT on older drivers too (random black screen / monitor disconnecting).  Back then, swapping to the monitor supplied DP cable fixed it, and seems to have fixed it since then.  It very well COULD just be my oddball monitor causing the issues on my end.

 

Regardless, swapped back to 22.5.1's and all is fine on my end.

Owned

 Share

CPU: Ryzen 3600 @ 4.3GHz, 1867MHz IF
AUDIO: Fosi Audio 300w Desktop Subwoofer Amp
MOTHERBOARD: ASRock B450M Pro 4
RAM: 32GB (2x16GB) GSkill DDR4-3600 @ 3733, 16-19-19-39
GPU: Ref Powercolor RX 5700XT @ 2050 / 1800
SSD/NVME: 1TB Mushkin Enhanced Pilot-E NVME
SSD/NVME 2: 3x 2TB Crucial BX500 RAID0
PSU: Silverstone 850w Gold
Full Rig Info

Owned

 Share

CPU: Phenom 9850
MOTHERBOARD: Asus M4A79 Deluxe
RAM: 8GB (4x2GB) Kingston HyperX DDR2-800
PSU: eVGA 600BQ
GPU: Sapphire Dual X HD6970 2GB
SSD/NVME: Crucial BX500 240GB
HDD: 2x Toshiba 3TB 7200RPM RAID0
CPU COOLER: T.R.U.E. 120
Full Rig Info

Owned

 Share

CPU: Ryzen 5800x
GPU: MSI RX 6900XT Triple X
PSU: Seasonic Focus GX Gold 1000w
CPU COOLER: EKWB EK-AIO Basic 240mm
MOTHERBOARD: Asus ROG Strix B550-I Gaming
SSD/NVME: Silicon Power 512GB Gen3 NVME
HDD: 2x WD Black 2.5" 500GB RAID0
RAM: Mushkin Redline Black 32GB (2x16GB) DDR4-4000
Full Rig Info
Link to comment
Share on other sites

My 5700 xt did have the same problem random black screens about a year ago.. Changed cable didnt help. Different hdmi port fixed it for me. Glad you got it figured out.

Owned

 Share

CPU: 5800x
MOTHERBOARD: Gigabyte x570 Elite wifi
RAM: T-Force 3600 DDR4 CL16 32 GB
PSU: Thermaltake 1350
GPU: 6800 XT
SSD/NVME: Samsung 980 512 GB
CPU COOLER: Ventoo V5
CASE: Antec P280
Full Rig Info
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

This Website may place and access certain Cookies on your computer. ExtremeHW uses Cookies to improve your experience of using the Website and to improve our range of products and services. ExtremeHW has carefully chosen these Cookies and has taken steps to ensure that your privacy is protected and respected at all times. All Cookies used by this Website are used in accordance with current UK and EU Cookie Law. For more information please see our Privacy Policy